Building a New Web Site



Getting Started
For this tutorial, you'll create a Web site with five pages, on which you will tell visitors about Corpus Christi and some of the things that you can do here. Until it is published for the first time, a Web site is a work in progress. If the task of putting together a whole site seems daunting to you, don't worry. You can gradually add information and other pages to your Web site until it is finished. Unlike printed letters, memos, and word-processing documents, Web sites can be dynamically changed or updated even after they've been published. You can add, delete, and modify text, pictures, and entire pages at any time.

With FrontPage, you can get started easily by simply typing text on the blank document that Page view provides. For this lesson, we'll begin with the home page  -- the default document that greets your visitors when they surf to your Web site.

To create a home page

The home page is the front door to your Web site. Greeting your visitors as you might do in person and providing some information about the content or subject matter of your site will spark interest in the people looking at your site. The home page also contains links to the other pages in a Web site.

1. On the blank page in Page view, type “Take a look around to learn more about our city and the things you can do here. We love Corpus Christi and we think you will too!”and then press ENTER. 

Most of the content that you will need for the web today has already been created so you have to a lot typing. That is really important because, as you will see, you (or your students) can create content in a variety of different programs (Word, PowerPoint, Excel, WordPad, etc) and easily import it directly onto a Web page without having to retype anything.

Your page should now look like this:
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Next, you will add a picture to the bottom of the current page. Pictures can be scanned photographs, drawings, or computer graphics created in a drawing or image-editing program.

For this example, the picture you'll insert is a graphical button of the FrontPage 2000 Web site logo.

To insert a picture on the home page

1. On the Insert menu, point to Picture, and then click From File. 

FrontPage displays the Picture dialog box. Because you are editing a page that isn't part of a Web site yet, FrontPage also opens the Select File dialog box, which lets you choose a picture to insert from your local file system.

The picture file you'll insert is located in the My Documents folder if you are doing this workshop at an ESC2 lab. If you are not at one of the Esc2 labs, the file that you need is located on the floppy disk that you were given at the beginning of the workshop.

2. In the Select File dialog box, navigate to the folder that contains the files. (The presenter will help you located the files.)
3. Click the file named createdwFP.gif and then click OK. (the “.gif” part of the file name may not show up on your computer.)
FrontPage inserts the selected picture file on the current page. It is a picture of a button that your site visitors will be able to click to learn more about FrontPage 2000.

4. Press ENTER to create a new line. 

Your page should now look like this:
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Merely inserting a picture of a button doesn't mean that anything will happen when someone clicks it in a Web browser. To make a picture or a word "clickable," it must have a hyperlink associated with it.

A hyperlink is a pointer from text or from a picture to another page or file on the World Wide Web. On the World Wide Web, hyperlinks are one important way to navigate between pages and Web sites.

In the next steps, you'll create a hyperlink from the button you just placed on the home page.

5. On the home page, click the picture of the FrontPage 2000 button you previously inserted. 

When a picture is selected, it is shown with file handles or sizing handles -- eight small squares around the outline of the picture. These can be used to resize a picture or change its appearance. When a picture is selected, FrontPage also displays the Pictures toolbar below Page view. The Pictures toolbar provides picture editing and formatting tools, which you'll learn about later. (If the Pictures toolbar is not visible when you click on a picture, click on View on the menu bar, select Toolbars – Picture.)
6. On the menu bar select Insert - Hyperlink. (Or you can click on the Hyperlink shortcut on the standard toolbar.) 

FrontPage displays the Create Hyperlink dialog box. Here, you specify the target of the hyperlink you are creating. This can be a page or a file in your Web site, on your local file system, on a Web server, or on another site on the World Wide Web.

Because you're creating a hyperlink from a button that is labeled "Microsoft FrontPage," you'll link to the Microsoft FrontPage home page on the World Wide Web. When site visitors click the button in a Web browser, they will be taken to the right place.

7. In the URL box, type www.microsoft.com/frontpage immediately after the http:// prefix that FrontPage has provided for you. 

URL is an acronym for Uniform Resource Locator. It is the technical term for what's commonly known as an "Internet address" or "Web site address." A URL specifies the unique location of a file or a collection of files on the World Wide Web.

8. Click OK to finish creating the hyperlink. 

You may notice that the appearance of the button itself hasn't changed. Unlike text hyperlinks, which change the color of the clickable text and underline it, picture hyperlinks do not automatically indicate the presence of the hyperlink in an obvious way. This is intentional, because changing the appearance of the picture could obscure the intended page design in some cases.

You can quickly check the existence of a hyperlink from a picture by moving the mouse pointer over the picture. If a hyperlink is present, FrontPage displays the URL the hyperlink points to on the status bar.

Next, you'll insert another graphic on the page, a copy of the City’s logo.
1. Select Insert – Picture – From File on the menu bar.
This time, FrontPage immediately displays the contents of the folder that contains your resources for the workshop. For the duration of each work session, FrontPage remembers the names and locations of the folders you've already navigated to.

2. In the Select File dialog box, double-click the file cityLogo. 

Double-clicking file names is faster than selecting each file and clicking OK.

FrontPage inserts the picture on the current page.

1. Press ENTER to move the text to the line below the picture. 

Your page should now look like this:
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To finish the home page, you'll center the text and pictures on it.

To center elements on a page

1. On the Edit menu, click Select All. 

FrontPage selects everything on the current page.

2. Select Format – Paragraph on the menu bar.
FrontPage displays the Paragraph dialog box. Here, you can change the alignment of selected elements, and apply indentation and custom spacing for text and graphics.

3. In the Alignment list, click Center, and then click OK. 

FrontPage centers the text and the pictures on the home page.

4. Click anywhere on the page to deselect all page elements. 

Now that you've invested some time and completed a number of steps, it's a good idea to save your page.

To save the current page

1. On the File menu, click Save As. 

FrontPage displays the Save As dialog box. Here, you can specify the location for the current page, and review or change the page title, the file name, and the file type.

2. In the Save As dialog box, click the My Documents icon on the vertical Places bar. 

The contents of your My Documents folder are displayed. If no files are displayed in the file list, then you currently do not have any other Web pages stored here.

3. Next to the Page title field, click the Change button. 

FrontPage displays the Set Page Title dialog box. Here, the default page title is based on the first line of text on the current page. A title identifies the contents of a page when it is displayed in a Web browser. For this tutorial, you'll change the page title to something more descriptive.

4. In the Set Page title box, type “Corpus Christi – Sparkling City By the Sea” and then click OK. 

In the Save As dialog box, the default file name is based on the first line of text on the current page. For this tutorial, change the file name to something more descriptive.

5. In the File name box, change the suggested text to “homepage,” and then click Save. FrontPage saves the current page.



Page View Options
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Page icon

While creating the home page, you've worked exclusively in normal Page view, but there are three different ways you can choose to look at the current page.

To display HTML tags on the current page

1. In Page view, click Reveal Tags on the View menu. 

FrontPage displays graphical representations of standard HTML tags for the current page. This display is useful for people who want to know where HTML tags are placed while they design their pages.

2. To hide the tags, click Reveal Tags on the View menu a second time. 

To display the HTML of the current page

1. In Page view, click the HTML tab at the bottom of the page. 

This is the HTML code that FrontPage has created so far while you were designing the home page. Web browsers decode these instructions to display the page. The HTML tab in Page view is intended for experienced Web developers and page designers who want to customize the HTML that FrontPage creates.

2. Click the Normal tab at the bottom of the page to return to normal Page view. 

To preview the current page

1. In Page view, click the Preview tab at the bottom of the page. 

Note   If you do not have Microsoft Internet Explorer installed on your computer, the Preview tab will not be displayed, and you will not be able to preview your pages this way. 

Looking at your page on the Preview tab is a quick and convenient way to see how certain elements -- including animations, movie clips, tables, and lists -- will appear in a Web browser.

2. Click the Normal tab at the bottom of the page to return to normal Page view once again.

Preview in Browser
There is another important tool that you can use to see what you page is going to look like in a browser and it is the browser itself. On the standard toolbar find the shortcut for “Preview in Browser” and click it. As you will see, your default browser opens and displays the current page in the browser just as it will appear on the web. This is a very useful tool, and one that you should use often while you are developing web pages and web sites.
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Creating a Web with FrontPage

A Web site is the collection of a home page and its associated pages, graphics, documents, multimedia, and other files. Web sites are stored on a Web server or on a computer's hard drive. FrontPage-based Web sites also contain files that support FrontPage-specific functionality and allow Web sites to be opened, copied, edited, published, and administered with FrontPage.

In the previous procedures, you learned how easy it is to create a Web page with FrontPage. As soon as you start the application, you can start typing and editing, then save the document to your hard drive -- much like a word processor. While you can certainly choose to put together an entire Web site like this, it can take a lot of manual work and attention to detail to maintain hyperlinks and source files, and keep your content up to date.

When you save your pages to a Web site, FrontPage can automatically manage and repair hyperlinks, organize files and folders, maintain dynamic navigation bars, check spelling across all pages in the Web site, and generate reports that point out problems with your pages and files.

To create a new Web site

1. On the File menu, click Close to close the current page. 

2. On the File menu, point to New, and then click Web. 

FrontPage displays the New dialog box. Here, you can choose from several Web site templates and wizards, specify where you want to save your Web site, and what you want to call it.

3. Make sure the One Page Web template is selected, and then press TAB. 

Pressing the TAB key moves the selection to the field where you specify the name and location of the new Web site.

4. In the Specify the location of the new Web box, change the suggested name to C:\My Documents\My Webs\CorpusChristi and then click OK. 

FrontPage creates a new Web site named "CorpusChristi" and displays its name in the title bar at the top of the FrontPage application window. Because you'll be working with several files in your Web site, FrontPage also displays the Folder List, where you can see the files and folders in your current Web site, similar to files and folders in Windows Explorer. You'll learn how to use the Folder List a little later.
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Navigation icon

5. Click the Navigation icon on the Views bar. 

When you have a Web site open, the icons on the Views bar let you look at the information in your Web site in different ways.

Navigation view shows a graphical representation of the structure of your Web site. Because you created a one-page Web site, FrontPage has automatically designated it as the Web site's home page -- indicated with a small icon of a house. While in Navigation view, FrontPage also displays the Navigation toolbar, which you can drag anywhere on your screen or close entirely which is my personal preference.

Next to the Views bar, FrontPage displays the optional Folder List, just like it did in Page view.

In a moment, you'll replace the new, empty home page with the one you created earlier. First, however, you'll create the structure for the other four pages that the Corpus Christi Web will have.

Creating a Web site structure in Navigation view enables features such as page banners and navigation bars that are automatically updated whenever you change, add, or remove pages in your Web site. This makes it easy to change things around. You'll learn more about these features later.

To create a navigation structure
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New Page button

1. In Navigation view, click the New Page button on the toolbar. 

FrontPage creates a new page labeled "New Page 1" below the home page. Pages in Navigation view aren't the actual pages in the current Web site; they are placeholders that point to them. This way, you can easily experiment with the structure and organization of a Web site before you create its content.

2. To quickly create the remaining three pages, hold down CTRL on your keyboard and press N three times. 

CTRL+N is a keyboard shortcut for the New Page command. FrontPage supports common Windows and Microsoft Office accelerator keys that help speed up repetitive tasks. The pages you just created appear below the home page, because the home page was selected when you issued the command.

In Navigation view, the selected page is blue, while others are yellow.

3. With the home page still selected, press TAB. 

Pressing the TAB key moves the selection to the next page in the structure and activates the page title for editing.

4. When New Page 1 is selected, type History and then press TAB. 

"History" is the page title of one of the pages you'll create for the Corpus Christi Web. Next, you'll specify the page titles for the other pages.

5. When New Page 2 is selected, type Attractions and then press TAB. 

6. When New Page 3 is selected, type Activities and then press TAB. 

7. When New Page 4 is selected, type Education and then press TAB.
8. With the homepage selected type Crystal City By the Sea and then press ENTER. 

Pressing ENTER after editing a page title saves the new title without selecting another page. To deselect all pages, click anywhere outside the pages in Navigation view.

Your screen should now look like this:
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You can quickly open pages in Page view for editing by double-clicking the pages in Navigation view or in the Folder List.

Next, you'll replace the blank home page FrontPage created from the Web site template by importing the home page you created and saved to your My Documents folder earlier in this lesson.

To import a page into a Web site

1. In Navigation view, double-click the Home Page to open it in Page view. 

FrontPage opens the blank home page that was created from the Web site template.
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Folder List button

2. On the toolbar, click the Folder List button to hide the Folder List in Page view. 

3. On the Insert menu, click File. 

FrontPage displays the Select File dialog box. Here, you can insert Web pages, word-processing documents, text files, and other documents on the current page.

4. In the Select File dialog box, navigate to the My Documents folder. 

5. When My Documents is displayed in the Look in list of the Select File dialog box, click the file named homepage, and then click Open. 

FrontPage imports your previously saved home page to the current page.
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Save button

6. To save the current page to your Web site, click Save on the File menu, or click the Save button on the toolbar. 

FrontPage displays the Save Embedded Files dialog box. Here, you can preview, rename, save, and update embedded files that the current Web site will use.

When you previously saved this page to the My Documents folder on your file system, FrontPage left the two pictures you inserted in their original location -- the FrontPage Tutorial folder. The home page merely pointed to the picture files without copying them to the same folder the page was saved to. To keep Web sites portable, however, you should always keep associated pages and files as part of the Web site that uses them.

1. In the Save Embedded Files dialog box, click OK. 

FrontPage saves the home page as Index.htm and saves copies of the embedded picture files, 2000.gif and Fp2000.gif, to the current Web site.



Creating Web Content

Now that the home page is part of the current Web site, you will create the content for the other pages in the Corpus Christi Web.

To edit the History page

1. Click the Navigation icon on the Views bar to switch back to Navigation view. 

Note that the Folder List now shows the picture files you saved to the current Web site. The file Index.htm is the new home page. You can later discard the remaining copy of the home page from your My Documents folder.

In the Folder List, the file names of the other pages were automatically derived from the page titles you typed into the pages in Navigation view. For this workshop, we won't change the names.

2. Double-click the History page to open it in Page view. 

This page will provide some historical information about Corpus Christi for site visitors. For this tutorial, we have provided this text for you, so you can simply insert it on the page without having to type it.

3. When the blank page is displayed in Page view, click File on the Insert menu. 

4. In the Select File dialog box, navigate to the folder that contains the files for the workshop.

5. Next, click the Files of type list and click Text Files (*.txt) to display the text files in the Tutorial folder. 

FrontPage displays the single file matching the criteria.

6. Click History of Corpus Christi in the list, and then click Open. 

The text you are inserting isn't saved in HTML format, so FrontPage displays the Convert Text dialog box to let you control how the text will be imported.

7. In the Convert Text dialog box, click Normal paragraphs with line breaks, and then click OK. 

FrontPage imports the text file and places it at the insertion point on the History page.

8. On the toolbar, click the Save button to save changes to the History page. 

Next, you will prepare the page titled Attractions. It will tell site visitors about some of our more popular tourist attractions that many will want to visit when they come to Corpus Christi.
To edit the Attractions page
1. On the toolbar, click the Folder List button to show the Folder List in Page view. 

2. Double-click attractions.htm in the Folder List to open the page in Page view. 

3. Click the Folder List button to hide the Folder List. 

4. When the blank page is displayed in Page view, click File on the Insert menu. 

5. In the Select File dialog box, click the Files of type list, and then click Rich Text Format (*.rtf) to display the formatted text file in the Tutorial folder. 

FrontPage displays the file matching the criteria.

6. Double-click the file AreaAttractions. 

Because this type of file contains formatting, FrontPage automatically converts the formatted text to HTML format.

7. On the toolbar, click the Save button to save changes to the Attractions page. 



Automatic Spelling Checks

Take a moment to scroll to the top of the History page. In the first paragraph, note the red, wavy underline under the word “gotta." 

In Page view, FrontPage automatically checks the spelling of text you type on the current page, just like Microsoft Word, PowerPoint, and other Microsoft Office applications do. An underlined word doesn't necessarily mean the word is spelled incorrectly. FrontPage may simply prompt you to verify unknown or suspected words, which happens most commonly with names of people and places.

If you know that the spelling of a suspected word is correct, you can either choose to ignore such words and keep them unchanged, or add them to a custom dictionary that FrontPage will keep for subsequent spelling checks. If the word is indeed misspelled, you can quickly insert the corrected spelling by right-clicking the suspected word and selecting a suggested correction.

There are three ways FrontPage can check spelling for you:

· Automatic spelling check as you type text 

· Manual spelling check of the current page 

· Cross-Web site spelling checks of all pages in a Web site

Page-based spelling checks are available in Page view by right-clicking suspect words or by clicking the Spelling command on the Tools menu. Cross-Web site spelling checks are available in every view. At the end of the day we will check spelling for the entire website at one time. 

Designing a Page

The History page will inherit its formatting from a graphical theme that you will apply to the Corpus Christi Web later. The Attractions page, however, requires some more design work which we will do now.
To help the reader differentiate the paragraph headings, list of attractions, and attraction details that the text on this page talks about, you will add some pictures, format paragraph styles, and create a bulleted list.

To create a bulleted list

1. With the Attractions page still displayed in Page view, find the words "Points of Interest." 

2. Click just to the left of the letter C in "Cole Park," hold down SHIFT, click just after the word "legend," in the Selena Memorial paragraph and then release SHIFT. 
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Bullets button

3. On the toolbar, click the Bullets button. 

FrontPage converts the selected text to a bulleted list.

4. Click anywhere on the page to deselect the list. 

Your page should now look like this:
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You can also create numbered lists with FrontPage. When you add new items to a numbered list, FrontPage automatically numbers them sequentially. You can add to bulleted and numbered lists by pressing ENTER after an item in the list. To end a list, press ENTER twice after typing the last list item. Just for practice let’s do another one.

1. Highlight “Mustang Island” through “Texas Maritime Museum”
2. On the toolbar click the Bulleted List button
3. Now highlight “Mustang Island State Park” through “Texas Treasure Casino Cruise.”
4. Click on the Increase Indent button on the Formatting toolbar to create a second level of bullets on your list. (You may have to click on it twice to get the desired results.)
5. Do the same for the list from “Aransas Wildlife Refuge” to “Texas Maritime Museum.”

6. Create two more bulleted lists in the “Kingsville” portion of the list and the “Around the Area” portion of the page.
Next, you will place some pictures on the current page and use positioning features in FrontPage to align the pictures with the paragraphs they are associated with. This will create a more interesting page layout.

To position pictures with text

1. With the Attractions page still displayed in Page view, scroll to the top of the page.
2. Click just to the left of the letter T in “Texas State Aquarium”, and then select Insert – Picture – From File on the menu bar. 

When you last inserted a picture, you did not have a Web site open, and FrontPage automatically displayed the Select File dialog box. Now that a Web site is open, FrontPage assumes you want to work with pictures that are already part of your Web site, and therefore displays the Picture dialog box.
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Select File button

3. Because you haven't yet added the picture you want to the current Web site, click the Select File button in the Picture dialog box. 

FrontPage displays the Select File dialog box.

4. Navigate to the location of the files for the workshop and click the file named “aquarium”, and then click OK. 

FrontPage inserts a picture of the a student at the Aquarium just before the current paragraph.

5. Next, click the picture to select it. 

6. On the Format menu, click Position. 

FrontPage displays the Position dialog box.

7. Under Wrapping style, click Left, and then click OK. 

8. Adjust the position of the picture as shown

9. On the toolbar, click the Save button to save changes to the Attractions page. 

10. In the Save Embedded Files dialog box, click OK. 

Your page should now look something like this:
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Art Center of Corpus Christi
100 Shoreline Bivd., (361) 884-6406
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You can either place pictures one by one in this way, or you can import all the pictures you will use on your pages all at once.

To add a group of files to the current Web site

[image: image15.png]


Folders icon

1. Click the Folders icon on the Views bar to switch to Folders view. (You can also do this in Page view using the folder list.)
Folders view is an expanded view of the Folders List that you have seen in Navigation and Page view. Similar to the way you look at files in Windows Explorer, here you can view details about the files and folders in your Web site, and perform such file management tasks as adding, deleting, moving, copying, and renaming files.

2. On the File menu, click Import. 

FrontPage displays the Import dialog box. Here, you can add files and folders from your local file system, a local area network, a company file server, or a resource on the Internet or World Wide Web, such as an FTP server.

3. In the Import dialog box, click Add File. 

4. In the Add File to Import List dialog box, navigate to the folder that contains the graphics for the workshop.
5. Next, click the Files of type list, and then click GIF and JPEG (*.gif, *.jpg) to display all picture files in the folder. 

6. Select 2GuysAtBeach, hold down the CTRL key and select all the other files listed except “aquarium,” “cityLogo,” and “createdwFP.” You have already placed them in  web so we don’t need to import them again.

FrontPage supports standard Windows file selection methods.

7. When the files are selected in the Add File to Import List dialog box, release CTRL, and then click Open. 

FrontPage adds the pictures you selected to the list in the Import dialog box.

8. Click OK to import the listed files to the current Web site. 

Now that the remaining pictures are added to your Web site, it's time to finish the layout of the Destinations page.

To finish the page layout

1. Click the Page icon on the Views bar to return to Page view. 

2. Click to the right of the sentence The USS Lexington Museum on the Bay. Select Insert – Picture – From File on the menu bar.
3. In the Picture dialog box, note that your previously imported pictures are now available, and then select the file lex.gif from the list. 

When you click a single picture file in the Picture dialog box, FrontPage displays a preview of the picture, so you can make sure it's the one you want to insert. This is one of the benefits of adding all your pictures to the Web site before inserting them on your pages.

The Picture dialog box also links to the clip art gallery that is included with FrontPage. And if you have a scanner or a digital camera, you can click the Scan button in this dialog box to acquire original pictures from those sources.

4. Click OK to insert the picture 

5. Click to Align Right button and position the picture as shown.

6. Next, scroll down to the “Corpus Christi Botanical Garden” paragraph and click to the left of the paragraph. Select Insert – Picture – From File on the menu bar.
7. Select the file botanical from the list, and then click OK. 

8. Select the picture, select Format – Position from the menu bar

9. Select Left for wrapping style and None for Positioning

10. Adjust the position of the picture as shown.

11. Insert the pictures “greyhound” and “dolphin” at the appropriate position on the page.

Positioning pictures and other page elements around text on your page makes for a more interesting design, much like pages in a magazine or newspaper. By positioning pictures in the margin, your page layout will be preserved even when the page is viewed at a different screen size and resolution in a Web browser.

Now we’ll add content to the last tow pages in the web, the activities page and educational opportunities page.


Creating the Activities page
The World Wide Web has a graphical interface, so it's no surprise that the most popular Web sites have pictures to look at. Scanners and digital cameras have become much more affordable, and many photo-developing places now offer to put your pictures on a CD-ROM so you can share them online.

While working with the graphics and clip art in the previous procedures, you saw how easy it is to place pictures on Web pages using FrontPage. In this part of the lesson, you'll create an online photo album of actual photographs of things to do in the Corpus Christi area. 
To edit the Things to Do page

1. On the toolbar, click the Folder List button to show the Folder List in Page view. 

2. Double-click activities.htm in the Folder List to open the page. 

3. Click the Folder List button to hide the Folder List. 

4. When the blank page is displayed in Page view, type “Things To Do” on the first line, then press ENTER. 

5. On the next line, type “Corpus Christi offers many opportunities for adventure and fun.  Click on each thumbnail picture below to see some examples and then use your Web browser’s Back Button to return to this page.” 

6. Press ENTER twice to create some space. 

Next, you'll place some pictures on the current page. But you aren’t just going to “throw them up” on the page; you are going to use a very important web page organization feature, the table. Using tables to organize content on a web page is very common and very important. Due to the limitations of HTML you can’t always arrange items on a page like you can with a word processing program. One way to overcome these limitations is through the use of tables. 

1. From the menu bar select Table – Insert – Table

2. Use the following settings:

· Five rows

· Four columns

· Center Aligned

· Specify width at 75%

· Border Size 0

· Cell padding 5

· Cell spacing 0

3. Click OK

4. In Row 2 Column 1 insert the kidfish picture. In Column 2 insert the redfish picture, and in column 4 insert the trout picture. Use drag and drop from the folder list.

5. Select all four cells in the first row.

6. Select Table – Merge Cells from the menu bar

7. Press the Center Align Button and type “Fishing”

8. Merge the second and third cells in row 2.

9. Merge all the cells in row 3, center align the cell and type “Windsurfing.”

10. In row 4 drag and drop windsurferf1024 to the second cell and windsurfing to the third cell.

11. Notice that the page will now take 124 seconds to load over a 28.8 modem. This is not acceptable. And besides, the page doesn’t look very good. Let’s fix that.

12. Select the first picture and click on the Auto Thumbnail button on the picture toolbar.

13. Repeat step 12 for each of the pictures on the page

14. Adjust the size of the pictures until they are about the same size.

15. Select all the cells in the table and click on the Center Align button on the Formatting Toolbar

16. Save the page. Notice that there are several new graphic files to embed. Do so.

17. If time permits, continue with pictures for the beach, sailing and sightseeing. 
By creating thumbnails -- small preview images of pictures -- you can give your visitors the choice of whether they want to spend time downloading the full-size pictures on your page. FrontPage makes creating thumbnails easy with the Auto Thumbnail tool. 
Your page should now look something like this:
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When FrontPage creates thumbnails, it doesn't actually modify the original picture files in any way. Instead, it quickly makes a copy of each picture, resizes it, downsamples the display resolution of the picture, inserts a hyperlink pointing to the original picture file, and adds a border around the thumbnail to indicate the presence of a hyperlink.

You can see why the Auto Thumbnail button is a real timesaver. Doing all of that manually for each picture could take a while. Also notice that this page will now only take 19 seconds to download. That is much better than 127 seconds.


Linking to Other Web Sites

Now only the Educational Opportunities page remains to be edited. For this workshop, this page will contain a list of text hyperlinks to some other sites on the World Wide Web.

When you create your own Web sites, you can create hyperlinks pointing to other Web sites that relate to the subject matter of your own pages. This lets visitors browse to similar sites without having to search for them.

To begin the Educational Opportunities page

1. On the toolbar, click the Folder List button to show the Folder List in Page view. 

2. Double-click education.htm in the Folder List to open the page in Page view. 

3. Click the Folder List button to hide the Folder List again. 

4. When the blank page is displayed in Page view, type “The Corpus Christi area has many educational opportunities. Click on the links below to learn more about them” and then press ENTER. 

Next, you will create a simple text animation of the paragraph heading. FrontPage includes a collection of fun text effects that you can easily apply to text headings or entire paragraphs.

To create a dynamic text effect

1. On the Educational Opportunities page, click anywhere in the text.
2. On the Format menu, click Dynamic HTML Effects. 

FrontPage displays the DHTML Effects toolbar. Here, you make sequential selections that will create a simple dynamic HTML (DHTML) script to animate the text when it is displayed in a Web browser.

Dynamic HTML is an extension of the HTML language that lets you create presentation effects for text and objects, much like in a Microsoft PowerPoint slide show. Using the DHTML Effects toolbar, you can add simple effects to your pages without the need to know programming.

3. In the On list, click Page load. 

This will instruct the Web browser to begin the effect when the page loads.

4. In the Apply list, click Hop. 

FrontPage applies the Hop effect. In a Web browser, this effect will cause each word to bounce onto the page.

5. Click the Close box in the upper right corner of the DHTML Effects toolbar. 

The DHTML Effects toolbar closes and the dynamic text effect is indicated in Page view with light blue shading.

Next, you will add text hyperlinks pointing to other sites on the World Wide Web. With FrontPage, you can create text hyperlinks in a number of ways, which you will learn next. When you create your own Web sites, you can create hyperlinks using your preferred method.

To create hyperlinks from text

1. On the Educational Opportunities page, press the DOWN ARROW key, and then type “Texas A&M University Corpus Christi” and then press ENTER. 

2. Click and drag the mouse over the words you just typed to select them. 

3. On the Insert menu, click Hyperlink. 

FrontPage displays the Create Hyperlink dialog box. Here, you specify the target of the hyperlink you are creating. This can be a page or a file in your Web site, on your local file system, on a Web server, or on another site on the World Wide Web.

4. In the URL box, type www.tamucc.edu immediately after the http:// prefix that FrontPage has provided for you, and then click OK. 

"HTTP" stands for Hypertext Transfer Protocol. This is the Internet protocol that allows World Wide Web browsers to retrieve information from Web servers. The text "www.tamucc.edu" is the URL of University.

5. On your keyboard, press the DOWN ARROW key to deselect the text. 

The words "Texas A&M University Corpus Christi" have changed from black default text to blue text, and the words are now underlined to indicate the presence of a hyperlink. When this page is displayed in a Web browser, clicking this hyperlink will retrieve and display the Texas A&M University Corpus Christi home page.

Next, you will create an automatic hyperlink. This method of creating hyperlinks is quick and easy, because it lets you bypass the Create Hyperlink dialog box.

To create an automatic hyperlink

1. On the Educational Opportunities page, press the DOWN ARROW key, type http://www.delmar.edu, and then press ENTER. 

As soon as you press ENTER (or the space bar), the URL you typed changes from black to blue text and is underlined to indicate the presence of a hyperlink. Like other Microsoft Office applications, FrontPage supports automatic hyperlink creation.

Since a URL by itself is not always very descriptive, however, you'll want to change it to the name of the site that the hyperlink points to. You can overtype the text without erasing the hyperlink.

2. Using the mouse, click and drag over the URL you just typed to select it. 

3. When the URL is selected, type “Del Mar College” to replace the selected text. 

The hyperlink still points to the same URL, but it is now labeled with the site's name.

Next, you'll create a hyperlink using your Web browser. This method of creating hyperlinks is the most accurate, because you actually visit the page the hyperlink will point to before creating the hyperlink. In addition, FrontPage copies the URL from the Web browser address field, so once the address is verified, you don't have to type it again.

If you do not have access to the World Wide Web while taking the FrontPage Tutorial, skip the following procedure and practice these steps the next time you're connected to the Internet. 

To create a verified hyperlink

1. Press the DOWN ARROW key to move the insertion point to the blank line below the previous hyperlink. 

2. Type Flour Bluff ISD and then press ENTER. 

3. Click and drag the mouse over the words you just typed to select them. 
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Hyperlink button

4. On the toolbar, click the Hyperlink button. 

FrontPage displays the Create Hyperlink dialog box. 
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Web Browser button

5. In the Create Hyperlink dialog box, click the Web Browser button. 

FrontPage starts your Web browser. When you visit the page that the hyperlink should point to and then switch back to FrontPage, the URL box will contain the address of the target page.

6. In your Web browser's Address (or Location) box, type http://www.flourbluffschools.net and then press ENTER. 

The Web browser displays the Flour Bluff ISD’s home page, where you can learn more about the district.

7. On your keyboard, press ALT+TAB (or click the Microsoft FrontPage taskbar button on the Windows taskbar) to switch back to the Create Hyperlink dialog box. 

The URL of the Flour Bluff ISD home page is now entered into the URL box in the Create Hyperlink dialog box.

8. Click OK. 

9. On your keyboard, press the DOWN ARROW key to deselect the text. 

The words "Flour Bluff ISD" are now underlined to indicate the presence of a hyperlink.

10. On the toolbar, click the Save button to save changes to the Educational Opportunities page. 

Your page should now look something like this:
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Add links for Corpus Christi ISD, Tuloso-Midway ISD, Calallen ISD, and Gregory-Portland ISD using one of the methods described above.


Formatting Paragraph Headings

Now that you have successfully created the content on all the pages in your Web site, you'll apply paragraph and font formatting to make the paragraph headings on all pages look consistent.

To apply paragraph styles to headings

1. On the Window menu, click history.htm. 

FrontPage brings the home page back into view. When you have more than one page open in Page view, you can use the Window menu to switch between them. The current page will always be listed at the top of this menu.

FrontPage brings the History page back into view.

2. Click anywhere in the heading Population: 275,000 at the top of the page. 

3. Click the Style list on the toolbar, and then click Heading 2. 

4. Click anywhere in the heading Origins 
5. Click the Style list on the toolbar, and then click Heading 3

6. Use the Format Painter to paint the Heading 3 setting to all the other headings in the document (The City Charter - Corpus Christi's Government, Water Resources In Corpus Christi, Culture And Recreation, and Safety in the City)

7. On the toolbar, click the Save button to save changes to the History page. 

Next, you'll finish formatting the page headings on the remaining two pages.

1. On the Window menu, click education.htm. 

2. Click anywhere in the sentence The Corpus Christi area has many educational opportunities. 

3. Click the Style list on the toolbar, and then click Heading 2. 

4. Click in the next line and make it heading 3

5. Select all the links on the page and make them heading 4.

6. On the toolbar, click the Save button to save the Links page. 

Designing and Publishing a Web



So far you’ve learned how easy it is to create Web pages with Microsoft FrontPage and then add them to a new Web site.

Now you'll continue working with the Corpus Christi Web you created by adding navigation bars to its pages, applying and customizing a graphical theme, previewing and testing the Web site, and then preparing the Web site for publication on the World Wide Web.

Before you publish a Web site, you'll want to make sure its pages and files are well organized, all of its hyperlinks are working, pages are free of spelling errors, and you have enough space available on the target Web server. FrontPage can help you complete these important tasks.

Enhancing the Appearance of a Web

While creating hyperlinks from pictures and text earlier in the workshop, you may have noticed that you don't have any connections yet between the pages in your Web site. Even if someone surfed to your current home page, they would have no way of getting to the other pages. In the next section, you'll learn how easy it is to make navigation hyperlinks to other pages.

To create hyperlinks to other pages

1. On the toolbar, click the Folder List button to show the Folder List in Page view. 

2. Double-click index.htm in the Folder List to open the home page in Page view. 

You'll keep the Folder List visible while you create hyperlinks to the other pages in your Web site.

3. When the home page is displayed in Page view, press CTRL+END to place the cursor at the end of the home page. 

4. Next, locate the page history.htm in the Folder List. 

The folders and files in the Folder List are shown in alphabetical order. The icon of each file gives you a clue about what kind of file it is.

You will now drag and drop the History page onto the bottom of the home page. When you do this, FrontPage will create a hyperlink to the History page on the home page.

5. Click and hold the mouse button on history.htm in the Folder List, move the mouse pointer on the line below the FrontPage button at the bottom of the home page, and then release the mouse button. 

FrontPage displays the shortcut mouse pointer while you drag the mouse to indicate that it will not actually insert the Background page, but will create a hyperlink pointing to it.

FrontPage inserts the page title of the History.htm file ("History") as the hyperlink text. The blue underlined text shows the presence of the hyperlink.

6. Repeat steps 4 and 5 with the other pages in the Corpus Christi Web, including Attractions.htm, Education.htm, and activities.htm. Place each link just after the previous one. 

7. On your keyboard, press the DOWN ARROW key to deselect the last hyperlink. 

Your page should now look like this:
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While you can manually create hyperlinks to the other pages in your Web site this way, doing so for all pages in a Web site can become a time-consuming and tedious task, especially for larger Web sites. Worse, if you decide to add or remove pages in the current Web site after creating hyperlinks, you'll have to manually add or remove the hyperlinks to them.

FrontPage has a better way to create, manage, and automatically update the navigation hyperlinks that connect your pages together. Before you learn how to do this, let's get rid of the four hyperlinks you just made.



Adding Shared Borders and Navigation Bars

For the Corpus Christi Web, you will let FrontPage manage the hyperlinks that site visitors will click to move around the pages in your Web site. FrontPage achieves this with a combination of two powerful features: shared borders and automatic navigation bars.

Shared borders are page regions reserved for content that you want to appear consistently throughout the pages in your Web site. These borders can contain page banners and navigation bars. Page banners display the page title you gave each page when you created or saved it. Navigation bars are a row or column of hyperlinks to the other pages in the current Web site. FrontPage can automatically update shared borders and navigation bars, so the navigation structure of your Web site will always work correctly, even when you add, move, or delete pages from the Web site's structure.

You have already completed the first step required for automatic navigation bars earlier in the workshop: creating the basic Web site structure in Navigation view. Because you have already done this, you'll now enable shared borders throughout your Web site.

To create shared borders across a Web site

1. Click the Navigation icon on the Views bar to switch to Navigation view. 

2. Click the Folder List button to hide the Folder List in this view. 

3. On the Format menu, click Shared Borders. 

FrontPage displays the Shared Borders dialog box. Here, you can specify where on your pages FrontPage should insert shared borders. Because your Web site structure has two levels of pages -- the home page and the pages below it -- you will use two kinds of shared borders and two kinds of navigation bars.

4. In the Shared Borders dialog box, make sure the All pages option is selected. 

5. For a horizontal shared border, select the Top check box and select the Include navigation buttons check box just below it. 

6. For a vertical shared border, select the Left check box and select the Include navigation buttons check box below it. 

7. Leave the Right and Bottom check boxes unchecked, and then click OK. 

FrontPage creates shared borders and default navigation bars for all the pages in the current Web site. You'll see what these look like when you return to Page view.

Next, you'll customize the appearance of the default navigation bars. Because they are shared across all pages in the current Web site, you can change their properties on any page and the change will be reflected across the entire Web site.

To test navigation bar hyperlinks

1. In Navigation view, double-click the Home Page. 

2. Click the Folder List button to hide the Folder List in Page view. 

Note the changes FrontPage has made to the home page. It now contains a top and left shared border. The top border contains a page banner with the name of the current page, and the left border contains a list of navigational hyperlinks that look exactly like the ones you manually created at the beginning of this lesson.

In Page view, you can easily test hyperlinks that point to pages and files in your Web site.

3. Hold down CTRL and then click the first navigational hyperlink named History on the left side of the page. 

FrontPage opens the page the hyperlink points to. On the History page that is now open, shared borders and navigation bars have also been inserted. On this page, however, the links to the other pages are displayed in the top border, just under the page banner. This is because FrontPage uses the Web site structure you created in Navigation view to determine the level the current page is on.

By default, the top shared border points to pages on the same level as the current one, whereas the left border points to pages below the current one. In the next section, we'll change this default to another design.

To customize navigation bars

1. On the Window menu, click index.htm. 

FrontPage brings the home page back into view.

2. In the top border of the home page, double-click the text that reads Edit the properties for this Navigation Bar to display hyperlinks here. 

Double-clicking a navigation bar opens the Navigation Bar Properties dialog box. Here, you can customize the appearance of a navigation bar and the hyperlinks it creates.

Currently, the horizontal navigation bar is set to link to pages on the same level. Since the home page is on its own level in your navigation structure of your Web site, there are no other pages on the same level. FrontPage therefore doesn't show any navigation bars in this shared border.

For the Corpus Christi Web, we want to have a horizontal navigation bar on the home page and vertical navigation bars on the other pages. To do this, we'll change the default setup of both navigation bars. You can make these changes on the current page and they'll be reflected throughout your Web site.

3. In the Navigation Bar Properties dialog box, click Child level, clear the check boxes for Home page and Parent page, and then click OK. 

FrontPage creates a navigation bar with hyperlinks to all the pages below the home page level.

4. Press HOME to deselect the navigation bar. 

Your page should now look like this:
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Note that the left navigation bar still contains the same set of hyperlinks as the top navigation bar. In the next steps, you'll remove the obvious redundancy, and format the left navigation bar so it is displayed only on the other pages that the home page points to.

5. In the left border of the home page, double-click the vertical navigation bar. 

6. In the Navigation Bar Properties dialog box, click Same level, select the Home page check box, and then click OK. 

FrontPage changes the navigation bar to the placeholder text that reads "Edit the properties for this Navigation Bar to display hyperlinks here." This text is only shown in Page view while you work; it will not appear in a Web browser.

By pointing the hyperlinks in this navigation bar to the same level as the home page, you are effectively removing the hyperlinks from the left border, because there are no pages on the same level as the home page. This also removes the redundancy between the horizontal and vertical navigation bars.

7. To save the home page, click Save on the File menu, or click the Save button on the toolbar. 

Your page should now look like this:
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8. On the Window menu, click history.htm. 

FrontPage brings the History page back into view.

Note that the changes you've made on the home page to both the horizontal and vertical navigation bars are automatically reflected here, as well as on all the other pages in your Web site.

[image: image23.png]


Excluding pages from navigation bars By default, all pages in your Web site's navigation structure are included in navigation bars. You can select pages to be excluded from your navigation bars by right-clicking the page in Navigation view and deselecting Included in Navigation Bars on the shortcut menu.



Applying a Theme

Although the addition of pictures, lists, forms, shared borders, and navigation bars has given the pages in the Corpus Christi Web a more streamlined and organized look, you may wonder what to do about the rather bland appearance of black and blue text on a white background. After all, this Web site is about a great city with a lot of things to offer. You want the pages to look more lively and fun.

Imagine how time-consuming it would be if you had to design a color scheme for text and graphics, and create graphical page banners, navigation buttons, list bullets, and background textures for all the pages in your Web site. Now imagine how many more custom graphics you would need to create if you maintained more than one Web site and you didn't want any of your Web sites to look the same.

FrontPage includes more than 50 professionally designed themes with matching color schemes that you can apply to any or all pages in your Web site. A theme consists of design elements for bullets, fonts, pictures, navigation buttons, and other graphics. When applied, a theme gives pages, page banners, navigation bars, and other elements of a Web site an attractive and consistent appearance.

To apply a theme to the Corpus Christi Web

1. On the Window menu, click index.htm. 

FrontPage brings the home page back into view.

2. On the Format menu, click Theme. 

FrontPage displays the Themes dialog box. Here, you can select from a list of themes that FrontPage installed by default, or choose to install the complete set of themes from your FrontPage 2000 CD-ROM. You can make choices about the appearance of the theme, preview theme elements, and modify the selected theme.

3. Click on some of the different theme names in the scrolling list box. 

When you click the name of a theme, the Sample of Theme window shows a sample of the graphical elements that are contained in the selected theme. This way, you can first preview a theme before applying it to selected or all pages in your Web site.

Before applying a theme, you can select theme options that affect the appearance of the theme's components. For example, selecting Vivid colors applies brighter colors to text and graphics, selecting Active graphics animates certain theme components, and selecting Background picture applies a graphical background to the pages in your Web site. You can also choose to apply a theme as a cascading style sheet (Apply using CSS).

4. Under Apply theme to, make sure All pages is selected. 

5. In the list of installed themes, click Network. 

6. Be sure the box for Active Graphics, Background Picture, and Vivid colors are checked and the one for CSS is not checked.
Since this is the first time you're applying a theme to a Web site, FrontPage displays a message to let you know that applying a theme will overwrite some of the manual formatting you may have done on your pages.

We've purposely not included much manual design work in this tutorial, so you can acknowledge this message and proceed to apply the theme.

7. Click Yes to apply the theme. 

The theme named "Artsy" is applied to all the pages in your current Web site.

8. To save the home page, click Save on the File menu, or click the Save button on the toolbar. 

Your page should now look something like this:
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As you can see, applying the theme has dramatically changed the appearance of the home page. The page banner and navigation buttons are no longer plain text; now they're colorful graphics and the page background has changed. 
Displaying graphical navigation buttons on all pages

1. On the Window menu, click History.htm. 

FrontPage brings the History page back into view.

Note that the page has inherited its theme and theme elements from the home page, but the vertical navigation bar in the left border still shows plain text hyperlinks. By default, vertical navigation bars are displayed as plain text, so they look this way even after you apply a theme. You can easily change navigation bar settings even after a theme is applied.

2. In the left border of the History page, double-click the vertical navigation bar. 

3. Under Orientation and appearance in the Navigation Bar Properties dialog box, click Buttons, and then click OK. 

4. Click anywhere on the page to deselect the navigation bar. 

FrontPage changes the navigation formatting and uses the graphical buttons included with the theme. The Web site now has an attractive and professional look.

5. To save the page, click Save on the File menu, or click the Save button on the toolbar. 



Modifying a Theme

Although the page banner of this theme looks nice, something directly related to the subject matter of the Corpus Christi Web might fit better. We've prepared a custom page banner that you will use to modify the current theme with. To modify a theme

1. On the Window menu, click index.htm. 

FrontPage brings the home page back into view.

2. On the Format menu, click Theme. 

FrontPage displays the Themes dialog box. In the list of themes, the Network theme is now the default theme because it has been applied to the current Web site.

3. In the Themes dialog box, make sure All Pages is selected. 

4. Next, click Modify. 

5. Under the question What would you like to modify? click Graphics. 

FrontPage displays the Modify Theme dialog box. Here, you can supply custom graphics for various theme elements such as page banners, navigation buttons, background pictures, and other elements. FrontPage superimposes text over these graphics, so there is no need to change graphics when you change the names of your pages, or add or remove pages.

For this example, we will change the graphical page banner on which FrontPage places the titles of the pages in the Corpus Christi Web.

6. In the Item list, click Banner. 

7. On the Picture tab, click the Browse button below the file name of the current banner graphic. 

FrontPage displays the Select Picture dialog box and shows the current pictures in your current Web site. Since the graphical banner we want to use isn't part of the Web site yet, you will search your file system for it.

8. In the Select Picture dialog box, click the Select File button. 

FrontPage displays the Select File dialog box.

9. Navigate to the folder that contains the files for the workshop.
10. Double-click the file ccbanner. 

FrontPage replaces the current page banner graphic with the custom graphic.

11. Click OK in the Modify Theme dialog box, and then click OK in the Themes dialog box. 

FrontPage displays a message asking you whether you want to save changes to the current theme.

12. Click Yes. Enter Corpus Christi as the title of the modified theme, and then click OK. 

FrontPage saves the modified theme and applies the new banner to all pages.

13. To save the page, click Save on the File menu, or click the Save button on the toolbar. 

Your page should now look something like this:
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Making your own themes 
For this tutorial, we've provided only a custom page banner to help show you how easy it is to customize existing themes. To create your own designs, repeat the steps in the previous procedure to customize other theme elements with your own custom graphics.

Congratulations, the Corpus Christi Web is almost finished! To make sure everything will look great on the World Wide Web, you'll now preview the Web site in your Web browser.



Organizing the Files in your Web

Now that your Web site contains several pages and files, you will use Folders view to organize them. Similar to Windows Explorer, Folders view lets you manage the files and folders in your Web site. You can safely rearrange the pages and files in your Web site without breaking hyperlinks, page banner titles, or navigation button labels.

In Folders view, FrontPage displays a hierarchical list of the folders in your Web site on the left side of the screen. Clicking on a folder in the Folder List displays its contents on the right side -- the Contents pane.
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In the following steps, you will move all the picture files in the Corpus Christi Web to the Images folder FrontPage created as part of the Web site.

If you were to use Windows Explorer or another file manager to move pages and files from one folder to another, you would break the hyperlinks between your pages and page elements. However, when you maintain your Web site in Folders view, FrontPage keeps every page and hyperlink in your Web site updated to keep track of the new locations of files and folders that have been moved.

To move picture files to the Images folder
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Folders icon

1. On the Views bar, click the Folders icon. 

FrontPage switches to Folders view.

2. In the Folder List pane, click the top-level folder labeled C:\My Documents\My Webs\Corpus Christi. 

3. In the Contents pane, click the Type column label. 

Clicking on a column label sorts the files in the Contents pane by that criteria. The first time you click a column label, the list is sorted in ascending order; when you click it a second time, it is sorted in descending order.

The list of files is now grouped by file type, with all GIF picture files at the top of the list, followed by HTM files (pages) in the middle, and all JPG pictures at the bottom of the list.

4. In the Contents pane, click the first picture file (aquarium.gif) at the top of the list to select it. 

5. Next, while holding down SHIFT, click the last GIF picture file in the list (windsurfing_small.gif). 
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In Folders view, FrontPage supports all standard Windows selection shortcuts, such as SHIFT+CLICK for selecting ranges of files, and CTRL+CLICK for selecting noncontiguous files.

6. Click and hold the right mouse button while the pointer is over any of the selected GIF file icons. 

7. Next, drag the mouse pointer over to the Images folder in the Folder List pane. 
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8. When the Images folder is selected, release the mouse button and click Move Here on the shortcut menu. 

FrontPage displays the Rename dialog box while it is moving the selected GIF image files to the Images folder because it is automatically updating all hyperlinks to these files in the current Web site.

9. Repeat steps 4 through 8 with all JPG picture files, starting with 2GuysAtBeach.jpg and ending with windsurfer1024_small.jpg. 

10. In the Contents pane, click the Name column label to arrange the remaining list of folders and files by their name again. 

You've successfully grouped all picture files in the Images folder.

When you work with your own Web sites, you can group sound files, movie clips, and other types of files in their own folders. You can create new folders in Folders view as needed and delete the ones you no longer need.

Final Changes

To make the front page look more appealing, more symmetrical, we are going to make a change to the top navigation bar. (I am not sure this will work in 2000. Play around with it to see if you can accomplish the same effect in 2000 and then add the instructions here.) 

1. Double click on the navigation bar to open the navigation properties. 

2. Change the radio button to Global Level and click OK

3. Click after the Front Page graphic and press the Enter key

4. Select Insert – Navigation from the menu bar
5. Select Link Bars and Based On Navigation Structure and click on Next

6. Select Use Page’s Theme and press Next

7. Press Finish

8. Select Child Level and remove the check from Home and Parent Page

9. Click OK

Now we are going to dress up the City Logo just a bit using a table.

1. Click to the left of the logo

2. Insert a one row, three column table

3. Set the properties to Center Alignment, do not specify width, and border set to zero.

4. Be sure the center cell is center aligned

5. Change the style of the words in the other two cells to Heading Two

6. Save your changes.
Spell Checking

While you can use automatic background spell-checking and per-page spell-checking in Page view, using the Spelling command in any view lets you check the spelling of all (or selected) pages across the current Web site.

You can check the spelling of page elements that can be edited directly on the page. Other text, such as page titles in page banners or text contained in FrontPage-based components, are not included in the spelling check.

To check spelling in the current Web site

1. On the Tools menu, click Spelling. 

FrontPage displays the Spelling dialog box. Here, you can specify whether FrontPage should check the spelling of selected pages only, or of the entire Web site.

2. In the Spelling dialog box, click Entire web, and then select the Add a task for each page with misspellings check box. 

FrontPage will add a task to the Tasks list for each page on which misspelled text is found. You will learn about Tasks view in the next section.

3. In the Spelling dialog box, click Start to begin the spelling check. 

FrontPage expands the Spelling dialog box to display the progress of the spelling check.

When the operation has been completed, FrontPage displays the misspelled words and the number of tasks that were added to the Tasks list in Tasks view.

4. Click Cancel to dismiss the Spelling dialog box. 

The spelling check is complete, but the corrections will not be made until you complete the tasks in the Tasks list.



Publishing the Corpus Christi Web

When you publish your Web site on the World Wide Web -- or your company intranet -- FrontPage automatically verifies your hyperlinks, the addresses of your pages, and the paths to your files.

Note   If you do not want to publish the Corpus Christi Web to your Web server, read this procedure for reference only, without actually completing the steps. 

To publish the Corpus Christi Web

1. Close all open pages in Page view. 
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Publish Web button

2. On the File menu, click Publish Web, or click the Publish Web button on the toolbar. 

FrontPage displays the Publish Web dialog box. Here, you specify the location on the World Wide Web or your corporate intranet to which you want to publish your Web site. Your Internet service provider can tell you this information.

You need Internet access through an Internet service provider before you can publish your Web site to the World Wide Web. If you want to sign on with a Web Presence Provider that can host FrontPage-enabled Web sites, click the WPPs button in the Publish Web dialog box.
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3. In the Publish Web dialog box, enter the URL of your target Web server, (such as http://example.microsoft.com/~myweb), and then click Publish. 

FrontPage publishes the current Web site from your computer to the World Wide Web or intranet Web server you specified.
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One-button publishing 
After you publish a Web site for the first time, you can bypass the Publish Web dialog box by using the Publish Web button on the toolbar. This quickly publishes any updates you've made to your pages without having to provide any information about the Web site's location. To again display the Publish Web dialog box, use the Publish Web command on the File menu instead of the toolbar button.

If FrontPage detects that you are publishing to a Web server that does not support the FrontPage Server Extensions, it will publish the current Web site via the FTP file transfer protocol.

If the Web server to which you are publishing your Web sites has the FrontPage Server Extensions installed, your Web sites will have full functionality of FrontPage-based components and Web scripts that you may have inserted on your pages.
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In the Answer Wizard, type:
What are the FrontPage Server Extensions?

Publishing Web sites to a Web server that does not have the FrontPage Server Extensions installed may disable some functionality contained on your pages, such as the feedback form you added. FrontPage will display informational messages during the publication process to alert you of such conditions.

During the publishing process, FrontPage displays a progress bar to indicate how much time is required to transfer your Web site to the target Web server.
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The speed at which FrontPage publishes your Web site depends on your connection speed, as well as the number and complexity of the pages and files in your Web site.
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Excluding pages from being published 
When you publish a Web site, all of its pages and files are published by default. To exclude pages or files from being published, right-click the page or file in a FrontPage view, click Properties on the shortcut menu, and select the Exclude this file when publishing the rest of the web check box on the Workgroup tab.

When FrontPage has successfully published your Web site, it provides a hyperlink to your new Web site in the confirmation dialog box. Click the link to open the published Web site in your Web browser.

Congratulations, you have successfully completed the Corpus Christi Web for this workshop. You are now ready to create and publish your very own FrontPage-based Web sites.
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